코딩테스트 문제/백준-자바

[백준] A+B - 3

유호야 2021. 5. 27. 14:33
반응형

10950번

 

문제

두 정수 A와 B를 입력받은 다음, A+B를 출력하는 프로그램을 작성하시오.

입력

첫째 줄에 테스트 케이스의 개수 T가 주어진다.

각 테스트 케이스는 한 줄로 이루어져 있으며, 각 줄에 A와 B가 주어진다. (0 < A, B < 10)

출력

각 테스트 케이스마다 A+B를 출력한다.

예제 입력1

5
1 1
2 3
3 4
9 8
5 2

예제 출력1

2
5
7
17
7

내 제출

import java.util.Scanner;

public class Solution{
    public static void main(String args[]){
        
        Scanner scn = new Scanner(System.in);
        int no = scn.nextInt();
        int[] score = new int[no];
        for(int i = 0; i < no; i++){
            int sum = 0;
            for(int j = 0; j < 2; j++){
                 sum +=scn.nextInt();
                if(j==1){
                    score[i] = sum;
                }
            }
        }
        
        for(int i = 0; i < score.length; i++) {
        	System.out.println(score[i]);
        }
    }
}

 

 

내 제출 2022-08-06

import java.util.*;

class Hello {
    public static void main(String args[]){
        Scanner scn = new Scanner(System.in);
        
        int no = scn.nextInt();
        scn.nextLine();
        String arrs[] = new String[no];
        
        int[] sum = new int[no];
        
        for(int i = 0; i < arrs.length; i++) {
        	arrs[i] = scn.nextLine();
        	sum[i] = Integer.parseInt(arrs[i].substring(0,1)) + Integer.parseInt(arrs[i].substring(2));
        }
        
        for(int i = 0; i < sum.length; i++) {
        	System.out.println(sum[i]);
        }
        
    }
}

Scanner / nextInt() 가 가진 버그를 발견했다.
Enter을 버퍼에 저장해놓는다는 것 

반응형

'코딩테스트 문제 > 백준-자바' 카테고리의 다른 글

[백준] 빠른 A+B  (0) 2021.05.28
[백준] N 찍기  (0) 2021.05.28
[백준] 평균  (0) 2021.05.24
[백준] 나머지  (0) 2021.05.24
[백준] 숫자의 개수  (0) 2021.05.24